Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Απάντηση
Άβαταρ μέλους
hocico0777
Δημοσιεύσεις: 43
Εγγραφή: Παρ Ιουν 29, 2012 09:35 am
Τοποθεσία: Larisa,Greece
Επικοινωνία:

Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από hocico0777 » Δευ Οκτ 08, 2012 11:23 am

Προχθές έκανα εγκατασταση τη mageia 2 (64 bit) κι όπως είναι φυσικό πρώτη δουλειά ήταν να εγκαταστήσω τον κλειστό οδηγό της κάρτας γραφικών.Οταν πήγα να εφαρμόσω τη γνωστή διαδικάσία μου εβγαλε ένα μηνυμα ότι δεν μπορει να κατεβάσει/βάλει κάποια πακέτα(δεν θυμάμαι ποια) κι αν θέλω να συνεχίσω με την εγκατάσταση.Ειπα ναι,εκανε την εγκατασταση,νομίζω οτι μου εβγαλε και καποιο μηνυμα στο τέλος (δεν θυμάμαι τι) και τωρα στην επανεκίνηση δεν μπορω να μπω στη mageia,σταματά σε μαύρη οθόνη.Αυτό με τα πακέτα παίζει να μου τα εκανε γιατι δεν ειχα ενεργοποιήσει το αποθετήριο core updates(πηγα να το ενεργοποιήσω αλλα μου εβγαζε σφάλμα).
Μπορώ να κάνω κάτι να το διορθώσω ή αναγκαστικά από την αρχή εγκατάσταση?
Hardware:intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz │Ram 4 GB │GPU nvidia gedorce 9600Gt Albatron│MB Asus P5K/PEU
OS:Windows 7 (64), Mageia 4 (64, kde)

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 933
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από dglent » Δευ Οκτ 08, 2012 12:00 pm

Σιγουρέψου ότι έχεις ενεργοποιημένο το αποθετήριο non-free
viewtopic.php?f=17&t=8

Δες και αυτό το βίντεο αν σε διευκολύνει:
http://www.mandrivalinux.gr/index.php?o ... d&Itemid=2

Αφού έχεις ενεργοποιήσει το αποθετήριο non-free, απεκατέστησε τα πακέτα nvidia που έχεις ήδη στο σύστημά σου με την εντολή:

Κώδικας: Επιλογή όλων

urpme -a nvidia
Στη συνέχεια μπορείς μέσω του κέντρο ελέγχου να εγκαταστήσεις τα πακέτα, ή αν δεν έχεις γραφικό περιβάλλον μέσω του drakconf



Αυτά μπορείς να τα κάνεις είτε από γραμμή εντολών ή εκτέλεσε το drakconf ή drakX11 και με τα βελάκια επέλεξε ως οδηγό για την κάρτα γραφικών vesa, και στη συνέχεια αφού επανασυνδεθείς θα έχεις γραφικό περιβάλλον και θα μπορείς να ενεργοποιήσεις το non-free και να εγκαταστησεις τους οδηγούς nvidia.

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 933
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από dglent » Δευ Οκτ 08, 2012 12:37 pm

Δες και αυτόν τον οδηγό:

Αποτυχία σύνδεσης στο γραφικό περιβάλλον έπειτα από ενημέρωση των οδηγών της κάρτας γραφικών:
http://www.mandrivalinux.gr/index.php?o ... &Itemid=37

Άβαταρ μέλους
hocico0777
Δημοσιεύσεις: 43
Εγγραφή: Παρ Ιουν 29, 2012 09:35 am
Τοποθεσία: Larisa,Greece
Επικοινωνία:

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από hocico0777 » Δευ Οκτ 08, 2012 19:26 pm

Eυχαριστώ για τις απαντησεις.Το αποθετήριο non free το ειχα ενεργοποιημενο,διαφορετικα δε σου βγαζει την επιλογη για εγκατασταση κλειστου οδηγού.
το θεμα ειναι οτι δε μου βγαζει σε οθονη localhost login για να κανω αυτα που λέει ο οδηγός πιο πάνω,οταν λέμε μαυρη οθονη,σκετο μαυρο-στην αρχη ελεγα κανει compile ton κερνελ στην καρτα αλλα μετα απο 10 λεπτα τιποτα.
το μονο που μπορω να σκεφτω ειναι μεσω εντολων τερματικού από live cd αλλα θα πρεπει με καποιο τροπο να κανω mount το συγκεκριμενο partition που βρισκεται ο φακελος που μπαινει ο οδηγός και να του πω που να κανει την εγκατασταση.
επισης χρησιμοποιω ασυρματη καρτα για δίκτυο.
Hardware:intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz │Ram 4 GB │GPU nvidia gedorce 9600Gt Albatron│MB Asus P5K/PEU
OS:Windows 7 (64), Mageia 4 (64, kde)

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 933
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από dglent » Δευ Οκτ 08, 2012 19:37 pm

Όταν φτάσεις στη μαύρη οθόνη, πάτα ctrl+alt+f1 ή f2 ή f3 .... f7 μέχρι να σε βγάλει σε τερματικό.

Άβαταρ μέλους
hocico0777
Δημοσιεύσεις: 43
Εγγραφή: Παρ Ιουν 29, 2012 09:35 am
Τοποθεσία: Larisa,Greece
Επικοινωνία:

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από hocico0777 » Τρί Οκτ 09, 2012 09:24 am

Στην περίπτωση μου ήταν ctrl+alt+F2.Eφαρμοσα τον οδηγό του παραπάνω λινκ κι ολα οκ.Να πω οτι ακόμη και με αυτη τη μέθοδο πάλι σε ρωτάει αν θελεις να χρησιμοποιήσεις τον ιδιόκτητο οδηγο κι εκει πρεπει να πεις οχι οποτε μπουταρεις με τον ανοιχτό δινεις urpme -a nvidia (ως root),εδώ μου ειπε κάτι για orphaned packages αλλα νομιζω οτι δεν υπάρχει πρόβλημα εφόσον εκανα παλι την εγκατασταση γραφικά με τη γνωστή διαδικασία.
Ευχαριστώ πολύ dglent.
Hardware:intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz │Ram 4 GB │GPU nvidia gedorce 9600Gt Albatron│MB Asus P5K/PEU
OS:Windows 7 (64), Mageia 4 (64, kde)

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 933
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από dglent » Τρί Οκτ 09, 2012 11:36 am

Μπορείς επίσης να επιλέξεις vesa αντί για την κάρτα γραφικών σου (nvidia) ώστε να ανακτήσεις το γραφικό περιβάλλον.
Στη συγκεκριμένη περίπτωση ποιο είναι το πρόβλημα με τον ιδιόκτητο οδηγό; Σε εμένα αντιθέτως είναι ο nouveau που μου δημιούργησε πρόβλημα μετά την εγκατάσταση, και με την ίδια διαδικασία εγκατέστησα τον ιδιόκτητο.
Τελευταία επεξεργασία από το μέλος dglent την Τρί Οκτ 09, 2012 13:40 pm, έχει επεξεργασθεί 1 φορά συνολικά.

Άβαταρ μέλους
hocico0777
Δημοσιεύσεις: 43
Εγγραφή: Παρ Ιουν 29, 2012 09:35 am
Τοποθεσία: Larisa,Greece
Επικοινωνία:

Re: Πρόβλημα με την εγκατάσταση ιδιόκτητου οδηγού nvidia

Δημοσίευση από hocico0777 » Τρί Οκτ 09, 2012 12:09 pm

Απλά δεν εγινε σωστη εγκατασταση του αρχικά.
Hardware:intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz │Ram 4 GB │GPU nvidia gedorce 9600Gt Albatron│MB Asus P5K/PEU
OS:Windows 7 (64), Mageia 4 (64, kde)

Απάντηση

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες