Μετάβαση από Mageia 1 σε Mageia Cauldron

Συζητήσεις σχετικά με προχωρημένες ρυθμίσεις της Mageia, όπως για παράδειγμα εγκατάσταση από το διαδίκτυο, ρυθμίσεις εξυπηρετητών, καθώς και συζητήσεις που αφορούν την έκδοση cauldron
Απάντηση
Άβαταρ μέλους
billver
Δημοσιεύσεις: 59
Εγγραφή: Τετ Ιούλ 27, 2011 13:38 pm

Re: Μετάβαση από Mageia 1 σε Mageia Cauldron

Δημοσίευση από billver » Κυρ Μάιος 06, 2012 17:50 pm

οπότε άμα χρειαστούμε κάποιο συγκεκριμένο πρόγραμμα να γράφουμε εδώ για το αν μπορέσεις να το ανεβάσεις στα αποθετήρια της κοινότητας?

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 898
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Μετάβαση από Mageia 1 σε Mageia Cauldron

Δημοσίευση από dglent » Κυρ Μάιος 06, 2012 19:05 pm

Ναι, είναι καλή ιδέα. Το καλύτερο είναι να υπάρχουν στα επίσημα αποθετήρια αλλά για πιο λόγο να περιμένεις τη mageia 3 για μια απλή ενημέρωση του προγράμματος. Εκτός και ο συντηρητής του συγκεκριμένου προγράμματος είναι αρκετά δραστήριος και το ενημερώσει εγκαίρως.

Στην περίπτωση που μια νέα έκδοση ενός προγράμματος έχει νέες εξαρτήσεις που απαίτουν μείζουσες αναβαθμίσης βιβλιοθηκών κλπ (πχ μια νέα έκδοση της Qt) θα πρέπει να περιμένουμε την επόμενη έκδοση της mageia ωστε να λάβουμε μαζί της και τη νέα έκδοση της εξάρτησης.

Άβαταρ μέλους
airmaik
Δημοσιεύσεις: 628
Εγγραφή: Τρί Ιουν 07, 2011 16:44 pm

Re: Μετάβαση από Mageia 1 σε Mageia Cauldron

Δημοσίευση από airmaik » Τρί Σεπ 25, 2012 23:01 pm

στον εναν δισκο εχω την mageia gnome και ειπα αφου εχω σαν σταθερο το mageia kde να πειραματιστο επανω σε αυτο

αλλαξα τα αποθετηρια του σε cauldron και εδωσα ενα

Κώδικας: Επιλογή όλων

urpmi --auto-update
μου βγαζει τα παρακατω πακετα για αναβαθμιση

Κώδικας: Επιλογή όλων

Πακέτο                         Έκδοση       Κυκλοφορία    Αρχιτεκ. 
(μέσο "core release")
  aria2                          1.15.2       1.mga3        x86_64  
  drakx-finish-install           14.45        1.mga3        x86_64  
  drakxtools                     14.45        1.mga3        x86_64  
  drakxtools-backend             14.45        1.mga3        x86_64  
  drakxtools-curses              14.45        1.mga3        x86_64  
  filesystem                     2.1.9        18.mga3       x86_64  
  glibc                          2.16         10.mga3       x86_64  
  harddrake                      14.45        1.mga3        x86_64  
  harddrake-ui                   14.45        1.mga3        x86_64  
  lib64db5.3                     5.3.21       1.mga3        x86_64  
  lib64ffi6                      3.0.11       1.mga3        x86_64  
  lib64gio2.0_0                  2.34.0       1.mga3        x86_64  
  lib64glib2.0_0                 2.34.0       1.mga3        x86_64  
  lib64parted2                   3.1          1.mga3        x86_64  
  lib64rpm3                      4.10.0       11.mga3       x86_64  
  lib64rpmbuild3                 4.10.0       11.mga3       x86_64  
  lib64rpmsign3                  4.10.0       11.mga3       x86_64  
  locales                        2.16         2.mga3        x86_64  
  locales-el                     2.16         2.mga3        x86_64  
  meta-task                      3            10.mga3       noarch  
  mgaonline                      2.78         2.mga3        noarch  
  perl                           5.16.1       7.mga3        x86_64  
  perl-CPANPLUS                  0.913.0      2.mga3        noarch  
  perl-Cairo                     1.101.0      1.mga3        x86_64  
  perl-Crypt-SSLeay              0.580.0      8.mga3        x86_64  
  perl-Curses                    1.280.0      8.mga3        x86_64  
  perl-DBI                       1.622.0      1.mga3        x86_64  
  perl-FCGI                      0.740.0      4.mga3        x86_64  
  perl-File-FnMatch              0.20.0       6.mga3        x86_64  
  perl-File-Sync                 0.110.0      2.mga3        x86_64  
  perl-Filesys-Df                0.920.0      8.mga3        x86_64  
  perl-Glib                      1.270.0      1.mga3        x86_64  
  perl-Gnome2-Vte                0.100.0      2.mga3        x86_64  
  perl-Gtk2                      1.245.0      1.mga3        x86_64  
  perl-Gtk2-Notify               0.50.0       5.mga3        x86_64  
  perl-Gtk2-SourceView2          0.100.0      6.mga3        x86_64  
  perl-Gtk2-WebKit               0.90.0       4.mga3        x86_64  
  perl-HTML-Parser               3.690.0      2.mga3        x86_64  
  perl-List-MoreUtils            0.330.0      2.mga3        x86_64  
  perl-Locale-gettext            1.50.0       7.mga3        x86_64  
  perl-Module-Build              0.400.300    2.mga3        noarch  
  perl-Module-Load-Conditional   0.540.0      1.mga3        noarch  
  perl-Net-DBus                  1.0.0        2.mga3        x86_64  
  perl-Object-Accessor           0.440.0      2.mga3        noarch  
  perl-Pango                     1.223        2.mga3        x86_64  
  perl-Params-Check              0.360.0      2.mga3        noarch  
  perl-String-CRC32              1.4          12.mga3       x86_64  
  perl-Term-ReadKey              2.30         13.mga3       x86_64  
  perl-Time-Piece                1.200.0      6.mga3        x86_64  
  perl-URPM                      4.14         1.mga3        x86_64  
  perl-WWW-Curl                  4.150.0      7.mga3        x86_64  
  perl-XML-LibXML                2.0.400      2.mga3        x86_64  
  perl-XML-Parser                2.410.0      2.mga3        x86_64  
  perl-base                      5.16.1       7.mga3        x86_64  
  python-rpm                     4.10.0       11.mga3       x86_64  
  rpm                            4.10.0       11.mga3       x86_64  
  urpmi                          7.8.1        1.mga3        noarch  
  userdrake                      1.13.6       2.mga3        x86_64  
(μέσο "core release32bit")
  perl-Archive-Tar               1.900.0      1.mga3        noarch  
  perl-Module-CoreList           2.720.0      1.mga3        noarch  
  rpmdrake                       5.37         1.mga3        noarch  
Θα χρησιμοποιηθεί επιπλέον χώρος 9.6MB στο σκληρό δίσκο.
25MB των πακέτων θα ανακτηθούν.
Συνέχιση με την εγκατάσταση των 61 πακέτων; (Y/n) 
οπου και παταω y και παίρνω αυτην την απάντηση

Κώδικας: Επιλογή όλων

εγκατάσταση meta-task-3-10.mga3.noarch.rpm aria2-1.15.2-1.mga3.x86_64.rpm από /var/cache/urpmi/rpms
Η εγκατάσταση απέτυχε:	rpmlib(X-CheckUnifiedSystemdir) is needed by filesystem-2.1.9-18.mga3.x86_64
	libc.so.6(GLIBC_2.15)(64bit) is needed by aria2-1.15.2-1.mga3.x86_64
με αποτέλεσμα να μην μπορώ να συνεχίζω ,καμια ιδεα?
Mageia4 x86_64 xfce4
Intel Core i5-3570 CPU @ 3.40GHz ‖ RAM 7892 MiB ‖ ASRock Z77 Extreme4-M
nVidia GK104 [GeForce GTX 760] [10de:1187] {nvidia}
eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)

Άβαταρ μέλους
dglent
Δημοσιεύσεις: 898
Εγγραφή: Τετ Ιουν 01, 2011 05:42 am
Τοποθεσία: Γαλλία

Re: Μετάβαση από Mageia 1 σε Mageia Cauldron

Δημοσίευση από dglent » Τετ Σεπ 26, 2012 04:47 am

Εγώ στο virtualbox εγκατέστησα την cauldron από ένα iso που κατέβασα.
Το πρόβλημα είναι η μεταφορά των υποκαταλόγων στο /usr

Δυστυχώς, θα πρέπει να ακολουθήσεις τα παρακάτω βήματα αν θέλεις να κάνεις αναβάθμιση, διαφορετικά νέα εγκατάσταση:
https://wiki.mageia.org/en/Feature:UsrM ... ease_Notes
https://forums.mageia.org/en/viewtopic.php?f=15&t=3111
https://bugs.mageia.org/show_bug.cgi?id=6854

Απάντηση

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης